您的位置:首页 > 其它

HDU-1358-Period-KMP

2018-02-08 11:43 435 查看

                                        Period

                                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                Total Submission(s): 10198    Accepted Submission(s): 4867


[align=left]Problem Description[/align] For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 
[align=left]Input[/align] The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 
[align=left]Output[/align] For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 
[align=left]Sample Input[/align]
3aaa12aabaabaabaab0 [align=left]Sample Output[/align]
Test case #12 23 3Test case #22 26 29 312 4 
#include<stdio.h>
int next[1000005];
void get_next(char s[],int n)
{
next[0]=-1;
int k=-1,j=0;
while(j<n)
{
if(k==-1||s[k]==s[j])
next[++j]=++k;
else k=next[k];
}
}
char s[1000005];
int main()
{
int n,c=1;
while(scanf("%d",&n)!=EOF&&n)
{
scanf("%s",s);
printf("Test case #%d\n",c++);
get_next(s,n);
for(int i=2;i<=n;i++)
{
int t=i-next[i];
if(i!=t&&i%t==0)
printf("%d %d\n",i,i/t);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: