您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence

2018-02-08 09:46 381 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33233    Accepted Submission(s): 13890


[align=left]Problem Description[/align]Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 
[align=left]Input[/align]The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 
[align=left]Output[/align]For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 
[align=left]Sample Input[/align]
213 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 1 313 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 2 1 
[align=left]Sample Output[/align]
6-1
#include<bits/stdc++.h>
using namespace std;
int text[1000003],p[10003],n,m,next1[10003];
void NEXT()
{
int k=-1,q=0;
memset(next1,-1,sizeof(next1));
while(q<m)
{
if(k==-1||p[k]==p[q])
k++,q++,next1[q]=k;
else k=next1[k];
}
}
int main()
{
int T;scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
int i,j;
for(i=0;i<n;i++)
scanf("%d",&text[i]);
for(i=0;i<m;i++)
scanf("%d",&p[i]);
NEXT();
int s=0,q=0,t=-1;
while(s<n)
{
if(q==-1||p[q]==text[s])
q++,s++;
else q=next1[q];
if(q==m)
{
t=s-m+1;break;
}
}
printf("%d\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: