您的位置:首页 > 其它

POJ 3292 Semi-prime H-numbers

2018-02-07 12:37 507 查看
Semi-prime H-numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:10306 Accepted: 4593
Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers
are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit,
and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different.
In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input
21
85
789
0


Sample Output
21 0
85 5
789 62

用素数筛选找出符合题目中要求的素数,
遍历每两个素数相乘。
代码:

#include<cstdio>
#include<string.h>
using namespace std;
int prim[400003],num[400003],K,L,k[1000003];
bool mp[1000005],t[1000003];
void init()
{
K=0,L=0;
memset(mp,1,sizeof(mp));
for(int i=5;i<=1000002;i++)
{
if((i-1)%4==0)
{
num[K++]=i;
if(mp[i])
{
prim[L++]=i;
for(int j=i+i;j<=1000002;j=j+i)
mp[j]=0;
}
}
}
memset(t,0,sizeof(t));
for(int i=0;i<L;i++)
{
if(prim[i]>1002)
break;
for(int j=i;j<L;j++)
{
if(prim[i]*prim[j]>1000002)
break;
else t[prim[i]*prim[j]]=1;
}
}
k[0]=0;
for(int i=1;i<=1000002;i++)
{
if(t[i])
k[i]=k[i-1]+1;
else k[i]=k[i-1];
}
}
int main()
{
init();
//printf("%d %d",K,L);
int n;
while(~scanf("%d",&n))
{
if(!n)break;
printf("%d %d\n",n,k
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: