您的位置:首页 > 其它

1038. Recover the Smallest Number (30)

2018-02-04 17:27 169 查看
1038. Recover the Smallest Number (30)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 10010;

bool cmp(string a, string b)
{
return a + b < b + a;
}

int main()
{
#ifdef _DEBUG
//freopen("data.txt", "r+", stdin);
fstream cin("data.txt");
#endif // _DEBUG

string str[MaxN] ,res;
int  N;
cin >> N;
for (int i = 0; i < N; ++i)
cin >> str[i];

sort(str, str + N, cmp);

for (int i = 0; i < N; ++i)
res += str[i];

while (res.size() > 0 && res[0] == '0')
res.erase(res.begin());

res.size() ? cout << res : cout << "0";

#ifdef _DEBUG
cin.close();
#ifndef _CODEBLOCKS
std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1038