您的位置:首页 > 其它

Periodic Strings UVA - 455

2018-02-04 12:49 369 查看
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k . For example, the string ” abcabcabcabc ” has period 3, since it is formed by 4 repetitions of the string ” abc ”. It also has periods 6 (two repetitions of ” abcabc ”) and 12 (one repetition of ” abcabcabcabc ”). Write a program to read a character string and determine its smallest period. Input The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input
1

HoHoHo

Sample Output
2


#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<iomanip>
//#define ll long long

using namespace std;

const int maxn = 10000;

string s;

bool test(int l){
for(int i = l; i < s.length(); i+=l)
{
for(int j = 0; j < l; j++)
if(s[j]!=s[j+i]) return false;
}
return true;
}

int Find()
{
int l = 0,ll = s.length();
for(int i = 1; i <= ll; i++){
if(ll%i != 0) continue;
if(test(i)) {
l = i;
break;
}
}
return l;
}

int main(){
int t;
scanf("%d",&t);
while(t--){
cin>>s;
printf("%d\n",Find());
if(t!=0) cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: