您的位置:首页 > 其它

HDU 3336 Count the string(kmp数组)

2018-02-04 11:54 429 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3336点击打开链接


Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 12288    Accepted Submission(s): 5682


Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

 

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n
4000
<= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

Sample Input

1
4
abab

 

Sample Output

6

 

根据next数组性质 一次判断后加起来即可

#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;
char t[4444444];
int n;
int nnext[4444444];
void getnext()
{
int ans=0;
int i=0,j=-1;
nnext[0]=-1;
while(i<n)
{
if(j==-1||t[i]==t[j])
{
i++;
j++;
nnext[i]=j;
if(nnext[i]!=0)
{
ans=(ans+1)%10007;
}
}
else
{
j=nnext[j];
//ans++;
}
}
printf("%d\n",(ans%10007+n%10007)%10007);
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
scanf(" %s",t);
getnext();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: