您的位置:首页 > 其它

Digit Counting UVA - 1225

2018-02-04 11:25 483 查看
Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 <N< 10000). After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is: 12345678910111213 In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.
Input

The input  le consists of several data sets. The  rst line of the input  le contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.
For each test case, there is one single line containing the number N.

Output

For each test case, write sequentially in one line the number of digit 0 ; 1 ;::: 9 separated by a space.
Sample Input
2
3
13

Sample Output

0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1


#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<iomanip>
#define ll long long

using namespace std;

const int maxn = 10000;
int l,a[10],vis[maxn];

string s;
void getnum(int x){
while(x){
int t = x%10;
s += (t + '0');
x/=10;
}
}

void get(){
memset(a,0,sizeof(a));
for(int i = 0; i < l; i++)
a[s[i]-'0']++;
}

int main()
{
int t;
scanf("%d",&t);
while(t--){
int n;
scanf("%d",&n);
for(int i = 1; i <= n; i++)
getnum(i);
//cout << s << endl;
l = s.length();
get();
s.erase();
printf("%d",a[0]);
for(int i = 1; i < 10; i++)
printf(" %d",a[i]);
cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: