您的位置:首页 > 其它

L - Charm Bracelet 寒假练习2-L

2018-02-04 09:21 197 查看
来源:poj3624

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6

1 4

2 6

3 12

2 7

Sample Output

23

题意概括:

bessie在商店买手串,手串需要用珠子串起来,每个珠子的重量和价值都不一样,给出bessie能带的最大重量求出手串的最大价值。

解题思路:

01背包问题,状态转移方程:dp[j]=max(dp[j],dp[j-w[i]]+c[i]);

代码:

#include<stdio.h>
#include<string.h>
int max(int x,int y);
int main()
{
int m,n,w[14030],c[14030],dp[14030];
while(scanf("%d%d",&m,&n)!=EOF)
{
memset(dp,0,sizeof(dp));
for(int i=0;i<m;i++)
{
scanf("%d%d",&w[i],&c[i]);
}
for(int i=0;i<m;i++)//表示物品编号
{
for(int j=n;j>=w[i];j--)//当体积为j时,装不装当前物品
{
dp[j]=max(dp[j],dp[j-w[i]]+c[i]);
}
}
printf("%d\n",dp
);
}
}
int max(int x,int y)
{
if(x>y)return x;
return y;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  01背包
相关文章推荐