您的位置:首页 > 其它

pat 1053 Path of Equal Weight(树的遍历,dfs)

2018-02-02 22:48 555 查看

1053. Path of Equal Weight (30)

时间限制
100 ms

内存限制
65536 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. Theweight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower
number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers
where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end
of the line.

Note: sequence {A1, A2, ..., An} is said to begreater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ...
k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2


题意:给你一棵树的的每个节点的权值,求所有从根节点到叶子节点的路径的路径和等于常数s的路径,如果存在多条,按从大到小的顺序输出

解:通过dfs遍历整棵树即可,不多说,代码注释很清楚。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<queue>
#include<vector>
#include<map>
#include<stack>
using namespace std;
#define inf 0x3fffffff
#define LL long long
#define mem(a,b) memset(a,b,sizeof(a))
const int N=110;
int m,n,s,path
;//注意path数组里面存的是路径的下标,不是节点的权值
struct node
{
int weight;
vector<int> child;//存储子节点序号
}node
;
bool cmp(int x,int y)
{
return node[x].weight>node[y].weight;//存入子节点时按全值从大到小存入,因为题目要求输出路径时按从大到小的顺序
}
//递归的三个参数:下标、经过的节点个数,权值之和
void dfs(int index,int numnode,int sum)
{
if(sum>s) return;//路径和大于s时直接返回结束
if(sum==s)
{
if(node[index].child.size()!=0) return ;//路径和等于s但仍存在子节点返回结束
for(int i=0;i<numnode;i++)
{
printf("%d",node[path[i]].weight);//通过path数组的下标来输出权值
if(i<numnode-1) printf(" ");
else printf("\n");
}
return ;
}
for(int i=0;i<node[index].child.size();i++)
{
int child=node[index].child[i];//child存的是子节点的序号
path[numnode]=child;//把序号存到path数组中
//注意三个递归的参数第一个是child不应该是index+1(我一开始写的是这个),因为找的是该子节点的子节点,一条路径上的节点
//后面两个参数都比较好写
dfs(child,numnode+1,sum+node[child].weight);
}
}
int main()
{
int id,child,k;
scanf("%d%d%d",&n,&m,&s);
for(int i=0;i<n;i++)
scanf("%d",&node[i].weight);
for(int i=0;i<m;i++)
{
scanf("%d%d",&id,&k);
for(int j=0;j<k;j++)
{
scanf("%d",&child);
node[id].child.push_back(child);
}
//子节点插入child数组后进行从大到小排序以满足输出路径时按从大到小的顺序
sort(node[id].child.begin(),node[id].child.end(),cmp);
}
path[0]=0;//先把第一个路径0存进来
dfs(0,1,node[0].weight);
}

上面的这段代码path数组里存的是节点的序号,但我一开始是想直接存权值的,下面这段代码path数组里存的就是权值,输出时直接输出path数组即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<queue>
#include<vector>
#include<map>
#include<stack>
using namespace std;
#define inf 0x3fffffff
#define LL long long
#define mem(a,b) memset(a,b,sizeof(a))
const int N=110;
int m,n,s,path
;
struct node
{
int weight;
vector<int> child;
}node
;
bool cmp(int x,int y)
{
return node[x].weight>node[y].weight;
}
void dfs(int index,int numnode,int weight)
{
if(weight>s) return;
if(weight==s)
{
if(node[index].child.size()!=0) return ;
for(int i=0;i<numnode;i++)
{
printf("%d",path[i]);
if(i<numnode-1) printf(" ");
else printf("\n");
}
return ;
}
for(int i=0;i<node[index].child.size();i++)
{
int child=node[index].child[i];
path[numnode]=node[child].weight;
dfs(child,numnode+1,weight+node[child].weight);
}
}
int main()
{
int id,child,k;
scanf("%d%d%d",&n,&m,&s);
for(int i=0;i<n;i++)
scanf("%d",&node[i].weight);
for(int i=0;i<m;i++)
{
scanf("%d%d",&id,&k);
for(int j=0;j<k;j++)
{
scanf("%d",&child);
node[id].child.push_back(child);
}
sort(node[id].child.begin(),node[id].child.end(),cmp);
}
path[0]=node[0].weight;//开始存入第一个节点的权值
dfs(0,1,node[0].weight);
}

又把这道题重新写了一遍,每次写法都不一样,不过感觉这次好理解一些

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<map>
#include<stack>
#include<queue>
#include<iostream>
using namespace std;
#define inf 0x3fffffff
#define LL long long
const int N=110;
struct nod
{
in
4000
t data;
vector<int>child;
}node
;
bool cmp(int x,int y)//注意cmp函数的写法
{
return node[x].data>node[y].data;
}
int m,n,s,path
;
void dfs(int index,int num,int data)
{
if(node[index].child.size()==0)
{
if(data!=s) return ;
path[num]=node[index].data;
for(int i=0;i<=num;i++)
printf(i==num?"%d\n":"%d ",path[i]);
return ;
}
path[num]=node[index].data;
for(int i=0;i<node[index].child.size();i++)
{
int tmp=node[index].child[i];
//第三个参数加的是node[tmp].data,不是node[index].data
dfs(tmp,num+1,data+node[tmp].data);
}
}
int main()
{
int k,father,sun;
while(~scanf("%d%d%d",&n,&m,&s))
{
memset(path,0,sizeof(path));
for(int i=0; i<n; i++)
{
node[i].child.clear();
scanf("%d",&node[i].data);
}
for(int i=0; i<m; i++)
{
scanf("%d%d",&father,&k);
for(int j=0; j<k; j++)
{
scanf("%d",&sun);
node[father].child.push_back(sun);
}
sort(node[father].child.begin(),node[father].child.end(),cmp);
}
dfs(0,0,node[0].data);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT STL dfs