您的位置:首页 > 其它

HDU1241 POJ1562 UVa572 UVALive5317 Oil Deposits【DFS】

2018-02-02 21:49 309 查看
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous
square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits
can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1
<= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2


#include <iostream>
#include<stdio.h>
#include<string.h>

using namespace std;
#define SIZE 8          //上下左右对角线一共八个方向;
struct direct
{
int drow;
int dcol;
}direct[SIZE]={{0,-1},{0,1},{-1,0},{1,0},{-1,1},{1,-1},{-1,-1},{1,1}};      //八个方向每个方向;

const int maxn=100;
char grid[maxn+2][maxn+2];      //油田

void dfs(int row,int col)
{
int i;
for(i=0;i<SIZE;i++)
{
int nextrow=row+direct[i].drow;
int nextcol=col+direct[i].dcol;
if(grid[nextrow][nextcol]=='@')         //如果跟他相邻则变为*;
{
grid[nextrow][nextcol]='*';
dfs(nextrow,nextcol);               //顺着当前这个看是否还有相邻的,若有相邻的仍然变为*;直到发现不了@为止;
}
}
}

int main()
{
int m,n,cnt;
while(scanf("%d%d",&m,&n)!=EOF)
{
if(m==0&&n==0)                      //结束条件;
break;
memset(grid,0,sizeof(grid));        // 清零:边界清零
for(int i=1;i<=m;i++)
scanf("%s",grid[i]+1);          //习惯上从(1,1)点开始;从(0,0)点搜索也可以。
cnt=0;                              //计数清零;
for(int i=1;i<=m;i++)
for(int j=1;j<=n;j++)
{
if(grid[i][j]=='@')
{
cnt++;
grid[i][j]='*';
dfs(i,j);               //深度优先搜索;
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: