您的位置:首页 > 其它

HDU_4474_数位bfs——经典搜索

2018-02-02 19:08 363 查看
Yet Another Multiple Problem

There are tons of problems about integer multiples. Despite the fact that the topic is not original, the content is highly challenging. That’s why we call it “Yet Another Multiple Problem”.

In this problem, you’re asked to solve the following question: Given a positive integer n and m decimal digits, what is the minimal positive multiple of n whose decimal notation does not contain any of the given digits?

Input

There are several test cases.

For each test case, there are two lines. The first line contains two integers n and m (1 ≤ n ≤ 104). The second line contains m decimal digits separated by spaces.

Input is terminated by EOF.

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) while Y is the minimal multiple satisfying the above-mentioned conditions or “-1” (without quotation marks) in case there does not exist such a multiple.

Sample Input

2345 3

7 8 9

100 1

0

Sample Output

Case 1: 2345

Case 2: -1

Source

2012 Asia Chengdu Regional Contest

mean:

第一行给你n,m;

第二行给你m个>=0 &&<10的整数;

求多少倍的n使每一位都不包含 这m个数字;

ans

这样的话 a%n=x ,(a+c)%n=x;a+c是>a要取最小所以就用mod 出的值来做 标记判重,后面搜索到的数是否能用,

#include<bits/stdc++.h>
using namespace std;
int n,m;
const int N=1e4+10;
int vis
,deal
,cnt;
struct node
{
int pre;
string str;
}num;
void bfs()
{
queue<node> q;
num.pre=0,num.str="";
q.push(num);
int i,j;
while(!q.empty())
{
node tmp=q.front();
q.pop();
for(i=0;i<cnt;i++)
{
num=tmp;
int x=num.pre*10+deal[i];
if(!x) continue;
x%=n;
if(!vis[x])
{
vis[x]=1;
num.pre=x;
num.str+=deal[i]+'0';
if(!x)
{
cout<<num.str<<endl;
return ;
}
q.push(num);
}
}
}
puts("-1");
return ;
}
int main()
{
int i,j,ca=0;
while(cin>>n>>m)
{
memset(vis,0,sizeof(vis));
int stu[111]={0};
cnt=0;
while(m--)
{
int x;
scanf("%d",&x);
stu[x]=1;
}
for(i=0;i<10;i++)
{
if(!stu[i])
deal[cnt++]=i;
}
printf("Case %d: ",++ca);
bfs();

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: