您的位置:首页 > 其它

A Mini Locomotive POJ - 1976

2018-02-02 10:40 344 查看
A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to
each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.

2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.

3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported
by the three mini locomotives.

Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:

The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i
th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed
1/3 of the number of passenger coaches.

Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input
1
7
35 40 50 10 30 45 60
2

Sample Output
240


题意概括:在车站有的时候需要用迷你火车头来拉乘客,现在知道车站有3个迷你火车头,给出每个迷你火车头可以拉几节车厢,已经n个车厢即每个车厢的乘客数,小火车必须拉连续的车厢,乘客不能换车厢。问3个迷你火车头最多能拉多少乘客?

解题思路:看完题也能想到这是一个贪心的问题。首先可以根据给出的火车头最多拉车厢的数max算出每max节车厢有多少乘客,然后对这些连续的max车厢的乘客数进行选择,但是如果选择一段车厢,那么后面算出的max节车厢会有冲突,需要把这些冲突的车厢跳过去。关键就是要退出状态转移方程,这题和01背包类似,对于每段max车厢都有拉或不拉两种情况,但是需要比较的不是前一次最多可拉多少乘客,因为这样被选车厢有冲突,所以需要和前max次比较。最后的方程就是

f[i][j]=max_(f[i-1][j],f[i-max][j-1]+sum[i]);当前最多可拉乘客数要么继承上一次的,要么是根据前max的更新一个新的最大值。

代码:

#include<stdio.h>
#include<string.h>
#define N 50010
int p
,sum
,f
[10];
int max_(int a,int b)
{
if(a<b)
a=b;
return a;
}
int main()
{
int i,j,t,n,max;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
memset(p,0,sizeof(p));
for(i=1;i<=n;i++)
{
scanf("%d",&p[i]);
}
scanf("%d",&max);
memset(sum,0,sizeof(sum));
for(i=1;i<=max;i++)
{
sum[1]+=p[i];
}
for(i=2;i<=n-max+1;i++)
{
sum[i]=sum[i-1]-p[i-1]+p[max+i-1];
}
// for(i=1;i<=n-max+1;i++)
// {
// printf("%d ",sum[i]);
// }
// printf("\n");
memset(f,0,sizeof(f));
// printf("%d\n",n-max+1);
for(i=1;i<=n-max+1;i++)
{
for(j=3;j>=1;j--)
{
f[i][j]=max_(f[i-1][j],f[i-max][j-1]+sum[i]);
//printf("%d ",f[i][j]);
}
// printf("\n");
}
printf("%d\n",f[n-max+1][3]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: