您的位置:首页 > 其它

Lake Counting(POJ-2386)

2018-02-02 10:28 399 查看
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.


Sample Output
3


代码如下:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
char z[110][110];
int n,m,dx[8]={-1,1,0,0,-1,-1,1,1},dy[8]={0,0,-1,1,-1,1,-1,1},vis[110][110];
struct pp
{
int x,y;
};
pp p[10010];
void dfs(int x,int y)
{
for(int i=0;i<8;i++)
if(!vis[x+dx[i]][y+dy[i]]&&z[x+dx[i]][y+dy[i]]=='W')
{
vis[x+dx[i]][y+dy[i]]=1;
dfs(x+dx[i],y+dy[i]);
}
}
int main()
{
while(cin>>n>>m)
{
memset(vis,0,sizeof(vis));
int cnt=0,s=0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
cin>>z[i][j];
if(z[i][j]=='W')
{
p[cnt].x=i;
p[cnt].y=j;
cnt++;
}
}
for(int i=0;i<cnt;i++)
if(!vis[p[i].x][p[i].y])
{
dfs(p[i].x,p[i].y);
s++;
}
cout<<s<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: