您的位置:首页 > 其它

HDU 1160 FatMouse's Speed(记录结果的最长上升子序列)

2018-02-02 08:48 453 查看


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18568    Accepted Submission(s): 8214
Special Judge


Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 

 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must
be the case that 

W[m[1]] < W[m[2]] < ... < W[m
4000

]

and 

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

 

Sample Output

4
4
5
9
7
就是求一个上升的子序列,然后记录序列中的值
#include<bits/stdc++.h>
int dp[1002];
using namespace std;
vector<int> p[1002];
struct node
{
int W,L,dec;
} mice[1002];
bool cmp(node a,node b)
{
if(a.W!=b.W)return a.W<b.W;
return a.L>b.L;
}
int main()
{
int t=0;
int i,j;
while(~scanf("%d%d",&mice[t].W,&mice[t].L))
{
t++;
mice[t-1].dec=t;
}
sort(mice,mice+t,cmp);
int mm=0,f;
for(i=0; i<t; i++)
{
dp[i]=1;
for(j=0; j<i; j++)
{
if(mice[j].L>mice[i].L&&mice[j].W<mice[i].W)
//sort排序并不能避免mice[i].W=mice[j].W的情况,这里
//还是要判断一下
{
if(dp[j]+1>dp[i])
{
dp[i]=dp[j]+1;
int L=p[j].size();
while(p[i].size()<L)
p[i].push_back(1);//先要为p[i]开辟足够的空间
for(int k=0; k<L; k++)
{
p[i][k]=p[j][k];
}
}
}
}
p[i].push_back(mice[i].dec);//每次循环完毕都保存了
//以i为结尾的最优结果
if(dp[i]>mm)
{
mm=dp[i];
f=i;
}
}
printf("%d\n",mm);
for(i=0; i<p[f].size(); i++)
printf("%d\n",p[f][i]);
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: