您的位置:首页 > 其它

Substrings HDU - 1238 (kmp+暴力枚举)

2018-02-01 22:14 375 查看

Substrings

HDU - 1238

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

Input The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings,
followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.

Output There should be one line per test case containing the length of the largest string found.

Sample Input
2
3
ABCD
BCDFF
BRCD
2
rose
orchid

Sample Output
2
2


暴力枚举子串,然后用kmp看是否含有这个子串

这里要求如果逆转的串是子串也行,所以用到了algorithm文件中的reverse函数

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
int Next[105];
void getNext(string w,int len){
int i = -1,j = 0;
memset(Next,0,sizeof(Next));
Next[0] = -1;
while(j < len){
if(i == -1 || w[i] == w[j]){
i++,j++;
Next[j] = i;
}
else
i = Next[i];
}
}
bool kmp(string w,int m,string s,int n){
int i = 0,j = 0;
getNext(w,m);
while(j < n){
if(i == -1 || w[i] == s[j])
i++,j++;
else
i = Next[i];
if(i >= m){
return true;
}
}
return false;
}
int main(){
int t;
scanf("%d",&t);
while(t--){
string str[102];
int ans = 0;
int n,i,j,k;
scanf("%d",&n);
for(i = 0; i < n; i++){
cin >> str[i];
}
for(i = 0; i < str[0].length(); i++){
for(j = i; j < str[0].length(); j++){//j从i开始,长度为1的串也要算
string w = str[0].substr(i,j-i+1);
for(k = 1; k < n; k++){
string rw = w;
reverse(w.begin(),w.end());
if(!kmp(w,w.length(),str[k],str[k].length())&&!kmp(rw,rw.length(),str[k],str[k].length()))
break;
}
if(k >= n){
if(w.length()>ans)
ans = w.length();
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: