您的位置:首页 > 移动开发

HDU 2830 Matrix Swapping II(最大子矩阵续)

2018-02-01 12:04 501 查看


Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2155    Accepted Submission(s): 1438


Problem Description

Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

 

Input

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

 

Output

Output one line for each test case, indicating the maximum possible goodness.

 

Sample Input


3 41011100100013 4101010010001

 

Sample Output


42Note: Huge Input, scanf() is recommended.

因为列可以随意变换,因此在搜索的时候只要满足所在行的dp比本身大就可以
而不必一定连续.
代码:

#include<bits/stdc++.h>
int n,m,dp[1002][1002];
char t[1002][1002];
using namespace std;
int main()
{
while(~scanf("%d%d",&n,&m))
{
int i,j;
for(i=0;i<n;i++)
scanf("%s",&t[i]);
memset(dp,0,sizeof(dp));
int ans=0;
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
if(t[j][i]=='1')
{
if(j==0)dp[j][i]=1;
else dp[j][i]=dp[j-1][i]+1;
}
}
for(i=0;i<n;i++)
{
int d[1002];
for(j=0;j<m;j++)
d[j]=dp[i][j];
sort(d,d+m);
int L=lower_bound(d,d+m,1)-d;
//找到第一个不为零的元素,遍历每一种可能
for(j=m-L;j>=1;j--)
ans=max(ans,j*d[L++]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: