您的位置:首页 > 产品设计 > UI/UE

hdu.Number Sequence

2018-01-31 17:02 666 查看


Problem Description


A number sequence is defined asfollows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple testcases. Each test case contains 3 integers A, B and n on a single line (1 <=A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end ofinput and this test case is not to be processed.

Output

For each test case, print the value off(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

 
如果用递归来做的话是要超时的
本题存在循环,我们找到第一个循环,算出多少一循环就好说了
另外 f(n) = x / 7;
说明f(n)
可能等于0 1 2 3 4 5 6
那个f(n-1)和f(n)最多的组合是7 – 7 =
49,可以知道循环最大为49,可以增加代码效率
以下代码:
#include<stdio.h>
intmain()
{
    int i, a, b, n;
    char f[50];
    while(scanf("%d %d %d",&a,&b ,&n) != EOF)
    {
        if(a == 0 && b == 0 &&n == 0)
        break;
        f[0] = 1;
              f[1] = 1;
        if(n == 1 || n == 2)
              {
            printf("1\n");
            continue;
        }
        for(i = 2; i <= 49; i++)
        {
            f[i] = (a * f[i - 1] + b * f[i -2]) % 7;
            if (f[i - 2] == 1 && f[i -1] == 1 && i != 2)     //找到第二组1 1
循环=i – 2,找到后break;
                            break;
        }
        printf("%d\n",f[(n - 1) % (i- 2)]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: