您的位置:首页 > 产品设计 > UI/UE

UVA10935 Throwing cards away I【模拟+queue+循环队列】

2018-01-29 19:39 543 查看
Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at thebottom. The following operation is performed aslong as there are at least two cards in the deck:

        Throw away the top card and move

        the card that is now on the top of the

        deck to the bottom of the deck.

  Your task is to find the sequence of discardedcards and the last, remaining card.



Input

Each line of input (except the last) contains anumber n ≤ 50. The last line contains ‘0’ andthis line should not be processed.

Output

For each number from the input produce twolines of output. The first line presents the sequenceof discarded cards, the second line reportsthe last remaining card. No line will haveleading or trailing spaces. See the sample for theexpected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

问题链接:UVA10935
Throwing cards away I

#include <iostream>
#include <queue>

using namespace std;

int main()
{
int n;

while(cin >> n && n) {
queue<int> q;

for(int i=1; i<=n; i++)

4000
q.push(i);

cout << "Discarded cards:";

bool nofirst = false;
while(q.size() >= 2) {
if(nofirst)
cout << ",";
nofirst = true;

cout << " " << q.front();

q.pop();
q.push(q.front());
q.pop();
}
cout << endl << "Remaining card: " << q.front() << endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: