您的位置:首页 > 其它

HDU 2058 The sum problem(数学)

2018-01-29 16:57 459 查看
The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 28609 Accepted Submission(s): 8604

Problem Description

Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10

50 30

0 0

Sample Output

[1,4]

[10,10]

[4,8]

[6,9]

[9,11]

[30,30]

[分析]

数学题

差为1的等差数列。

公式:Sn=(a1+an)*n/2(注意,后面说的n和题目中的N是不同的n,这里的n代表长度,代码中为len)

超大数字,容易TLE,诀窍在于找出小数字,而后枚举。

关键的小数字是公式中的n

也就是数列的长度,这个不大,小于sqrt(2*m)

至于为什么是sqrt(2*m),这个解释起来有点麻烦,需要思考。将公式变形,将n移项后得

2*m/(a1+an)=n

因为a1+an必然大于n所以,n必然小于sqrt(2*m)。

所以枚举n就可以

[代码]

#include<cstdio>
#include<cmath>
int main()
{
int n, m;
while (scanf("%d %d", &n, &m) != EOF)
{
if (!n && !m)break;
int len = sqrt(2 * m)+1;
//printf("%d\n", len);
while (--len)
{
int a = (2 * m) / len - len + 1;
a = a / 2;
if (len*(2 * a + len - 1) / 2 == m)printf("[%d,%d]\n", a, a + len - 1);
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: