您的位置:首页 > 其它

HDU 1003 Max Sum(线性DP)

2018-01-29 14:46 489 查看
Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

思路:

以每个点为结尾  求该点最大子序列和。

设i点权值为b,i-1点最大子序列和为a,  如果a是负数那么  以该点为结尾的最大子序列和为b,否则为a+b。

代码:

#include<stdio.h>
#define max(a,b) (a>b?a:b)

int main()
{
//l存储子序列和最大的左边界,r存储子序列和最大的右边界,c暂存当前序列左边界
//a存储前i-1项最大子序列和,b存储当前i项权值,maxn存储子序列最大和
int T,n,i,a,b,maxn,cnt=0,l,r,c;
scanf("%d",&T);
while(T--)
{

scanf("%d%d",&n,&a);
maxn=a,l=1,r=1,c=1;
for(i=2;i<=n;i++)
{
scanf("%d",&b);
if(a<0)c=i,a=b;
else a+=b;

if(a>maxn)
{
l=c;
maxn=a;
r=i;
}
}
if(cnt++)printf("\n");
printf("Case %d:\n%d %d %d\n",cnt,maxn,l,r);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: