您的位置:首页 > 其它

动态规划之最长上升子序列 HDU1950

2018-01-28 23:13 274 查看
最长上升子序列问题求的是形如一个数列a={4,2,3,1,5},那么这个数列的最长上升子序列就是{2,3,5}
求解这种问题有两种方法,第一种是求当前元素之前元素的最长上升子序列,得到递推公式dp[i]=max(1,dp[j]+1)意思是仅当前元素或者前一元素递推得到的最长上升子序列+当前元素,第二种是求相等长度的上升子序列,最后一个元素越小,则该子序列的“上升潜力”越大

方法一:

int dp[maxn];
int num[maxn];
int slove()
{
int res=0;
for(int i=0;i<n;i++)
{dp[i]=1;
for(int j=0;j<i;j++)
if(num[i]>num[j])

dp=max(dp[i],dp[j]+1);
res=max(dp[i],res);
}
return res;
}


 方法一的弊端在于其时间复杂度为n^2,在解决一些问题时会超时,在后文中有一个例子

方法二:

int dp[maxn];
int num[maxn];
int INF=0x3f3f3f3f;
int solve()
{
memset(dp,INF,dp+n);
for(int i=0;i<n;i++)
*lower_bound(dp,dp+n,num[i])=num[i];
print("%d\n",lower_bound(dp,dp+n,INF)-dp);
}


 方法二的时间复杂度为nlogn,比方法一快,但是处理的问题类型比较单一

例题HDU1950

Bridging signals

[b]Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3315    Accepted Submission(s): 2085
[/b]

[align=left]Problem Description[/align]'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?



Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do. 
[align=left]Input[/align]On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side. 
[align=left]Output[/align]For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other. 
[align=left]Sample Input[/align]
4642631510234567891018876543219589231746 [align=left]Sample Output[/align]
3914 这个问题我一开始用方法一来做,不出所料超时了
#include<iostream>
#include<cstdio>
using namespace std;
int num[41000];
int dp[41000];
int res(int n)
{
int ans=0;
for(int i=0;i<n;i++)
{  dp[i]=1;
for(int j=0;j<i;j++)
if(num[i]>=num[j])
dp[i]=max(dp[i],dp[j]+1);
ans=max(ans,dp[i]);
}
return ans;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
printf("%d\n",res(n));
}
}
用方法二,轻松就过了
#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int dp[40010];
int num[40010];
#define INF 0x3f3f3f3f
int main()
{
int t;
scanf("%d",&t);
while(t--)
{ int n;
memset(dp,INF,sizeof(dp));
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&num[i]);
for(int i=0;i<n;i++)
*lower_bound(dp,dp+n,num[i])=num[i];
printf("%d\n",lower_bound(dp,dp+n,INF)-dp);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: