您的位置:首页 > 其它

HDU 1051 Wooden Sticks(贪心)

2018-01-28 13:04 288 查看


Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23538    Accepted Submission(s): 9557


Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

 

Output

The output should contain the minimum setup time in minutes, one per line.

 

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

 

Sample Output

2
1
3
按长度从小到大排序,若长度相同,按重量从小到大排。
即求最少升序子序列
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
int start,end1;
}g[5003];
bool cmp(node a,node b)
{
if(a.start!=b.start)
return a.start<b.start;
else return a.end1<b.end1;
}
int main()
{
int T;scanf("%d",&T);
while(T--)
{
int n;scanf("%d",&n);
int i,j;
for(i=1;i<=n;i++)
scanf("%d%d",&g[i].start,&g[i].end1);
sort(g+1,g+n+1,cmp);
bool vis[5003];memset(vis,0,sizeof(vis));
int ans=0;
for(i=1;i<=n;i++)
{
if(!vis[i])
{
vis[i]=1;int m=g[i].end1;
ans++;
for(j=i+1;j<=n;j++)
if(!vis[j]&&g[j].end1>=m)
{
m=g[j].end1;
vis[j]=1;
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: