您的位置:首页 > 其它

POJ 3280 Cheapest Palindrome(经典区间dp)

2018-01-27 22:03 387 查看
Cheapest Palindrome

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:11351 Accepted: 5407
Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of
inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated
costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 

Line 2: This line contains exactly M characters which constitute the initial ID string 

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800


Sample Output
900


Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

dp[i][j]字符串从i到j变成回文串所需要的花费
则可以从区间长度为2开始遍历
若t[i]==t[j],则dp[i][j]=dp[i+1][j-1];
若dp[i+1][j]为回文串,则要把dp[i][j]变为回文串有两种操作
1.把第i个删掉,或在j后加上t[i],通过删或加都能使之变为回文串
因此取小的;即dp[i][j]=min(dp[i][j],dp[i+1][j]+a[i]);
2.把第j个删掉或在i前加上t[j],同理
dp[i][j]=min(dp[i][j],dp[i][j-1]+a[j]);
代码:
#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
const int INF=0x3f3f3f3f;
int a[150],dp[2002][2002];
using namespace std;
int main()
{
int n,m;scanf("%d%d",&n,&m);
char t[2003];
scanf("%s",&t);
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
char tt;int x,y;
cin>>tt>>x>>y;
a[tt]=min(x,y);
}
int L=strlen(t);
for(int i=1;i<L;i++)
{
for(int j=0,k=i;k<L;k++,j++)
{
dp[j][k]=INF;
if(t[j]==t[k])dp[j][k]=dp[j+1][k-1];
else
{
dp[j][k]=min(dp[j+1][k]+a[t[j]],dp[j][k-1]+a[t[k]]);
}
}
}
printf("%d",dp[0][L-1]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: