您的位置:首页 > 其它

POJ 3254 Corn Fields 【状压dp】

2018-01-27 21:17 429 查看
Corn Fields

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17619 Accepted: 9286
Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 

Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9

Hint

Number the squares as follows:
1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

#include<iostream>
#include<cstring>
using namespace std;
#define mem(x) memset(x, 0, sizeof x)
const int mod = 1e8;
const int MAX = 1 << 13;
int vis[MAX], maps[MAX], dp[13][MAX];
bool judge_place(int x)
{
return x & (x << 1);
}
bool judge_line(int i, int j)
{
return maps[i] & vis[j];
}
int main()
{
ios::sync_with_stdio(false);
int n, m;
while(cin >> n >> m)
{
mem(maps);
mem(dp);
mem(vis);
for(int i = 1; i <= n; i++)
for(int j = 1, x; j <= m; j++)
{
cin >> x;
if(!x)
maps[i] += (1 << (j - 1));
}
int num = 0, ans = 0;
for(int i = 0; i < (1 << m); i++)
if(!judge_place(i))
vis[num++] = i;
for(int i = 0; i < num; i++)
if(!judge_line(1, i))
dp[1][i] = 1;
for(int i = 2; i <= n; i++)
for(int j = 0; j < num; j++)
if(!judge_line(i, j))
for(int k = 0; k < num; k++)
if(!(vis[j] & vis[k]))
dp[i][j] += dp[i - 1][k];
for(int i = 0; i < num; i++)
ans = (ans + dp
[i]) % mod;
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: