您的位置:首页 > 其它

2018_1_27_Adding Reversed Numbers_大数不熟的来做

2018-01-27 20:05 239 查看
Adding Reversed Numbers

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18873 Accepted: 10147
Description
The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously,
this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted
into the comedy play.

Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros
are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.

ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before
reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers
you are to add.
Output
For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.
Sample Input
3
24 1
4358 754
305 794

Sample Output
34
1998
1

Source
Central Europe 1998
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
int num[3][1000];
void read(int ord){
int flag=0;
string tmp;
cin>>tmp;
for(int i=tmp.length()-1;i>=0;i--){
if(tmp[i]>'0')flag=1;
if(flag)num[ord][++num[ord][0]]=tmp[i]-'0';
}
for(int i=num[ord][0],j=1;i>j;i--,j++)
swap(num[ord][i],num[ord][j]);
}

void add(){
num[2][0]=max(num[0][0],num[1][0]);
for(int i=1;i<=num[2][0];i++)
num[2][i]=num[0][i]+num[1][i];
for(int i=1;i<=num[2][0];i++){
num[2][i+1]+=num[2][i]/10;
num[2][i]%=10;
}
if(num[2][num[2][0]+1]>0)
num[2][0]++;
int flag=0;
for(int i=1;i<=num[2][0];i++){
if(num[2][i]>0)flag=1;
if(flag)printf("%d",num[2][i]);
}
printf("\n");
}
int main(){
int n;
cin>>n;
while(n--){
memset(num,0,sizeof(num));
read(0);
read(1);
add();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: