您的位置:首页 > 其它

hdu 3294 Girls' research(manacher)

2018-01-27 19:59 453 查看

Girls' research

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 3445    Accepted Submission(s): 1305


[align=left]Problem Description[/align]
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:

First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……,
'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".

Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

[align=left]Input[/align]
Input contains multiple cases.

Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.

If the length of string is len, it is marked from 0 to len-1.
 

[align=left]Output[/align]
Please execute the operation following the two steps.

If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".

If there are several answers available, please choose the string which first appears.
 

[align=left]Sample Input[/align]

b babd
a abcd

 

[align=left]Sample Output[/align]

0 2
aza
No solution!

 

[align=left]Author[/align]
wangjing1111
 

[align=left]Source[/align]
2010 “HDU-Sailormoon” Programming Contest 

题意:

如果所给的字符串中有回文串,那么输出长度最大的回文串。并且按真正的字符输出出来。

思路:

用manacher跑一边,记录最长的回文串在原始数组中的左右下标,然后按照(a[i]-tmp+26)%26+97的真正的字符输出出来就行了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1010000;
int N,maxr[maxn];
char a[maxn],b[maxn],tmp;
int l,r;
void init()
{
int i;
l=r=0;
for(i=0;a[i];i++)
{
b[2*i+1]='#';
b[2*i+2]=a[i];
}
N=2*i+1;
b[0]='$',b
=b[N+1]='#';
}
void solve()
{
int id,maxn=0,ans=0;
for(int i=1;i<=N;i++)
{
maxr[i]=i<maxn?min(maxn-i,maxr[2*id-i]):1;
while(b[i+maxr[i]]==b[i-maxr[i]]) maxr[i]++;
if(i+maxr[i]>maxn) maxn=i+maxr[i],id=i;
if(maxr[i]-1>ans)
{
int len=maxr[i]-1;
ans=maxr[i]-1;
l=(i-len+1)/2-1;
r=(i+len-1)/2-1;
}
}
}
int main()
{
while(cin>>tmp)
{
scanf("%s",a);
init();
solve();
if(l==r)
printf("No solution!\n");
else
{
printf("%d %d\n",l,r);
for(int i=l;i<=r;i++)
{
printf("%c",(a[i]-tmp+26)%26+97);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: