您的位置:首页 > 其它

Farm Irrigation ZOJ - 2412

2018-01-27 17:58 309 查看
enny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from
A to K, as Figure 1 shows.



Figure 1
Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like



Figure 2
Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A
negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output
For each test case, output in one line the least number of wellsprings needed.

Sample Input
2 2
DK
HF

3 3
ADC FJK IHE
-1 -1


Sample Output
2
3


题意概括:给从A-K 11个字母,分别代表11中不同的水管,给一个n*n的由上述11个字母组成的矩阵,问这些字母代表的水管组成的灌溉网络至少需要几个供水点?

解题思路:先对11个字母代表的水管用一个3*3的矩阵表示,然后对输入的所有字母进行处理,组成一个3n*3n的矩阵由1和0组成,然后将矩阵当成普通的图深搜一遍,找出有几个单独的段。

代码:

#include<stdio.h>
#include<string.h>
int m,n;
int a[200][200],book[200][200];
int b[20][10][10]={
{{0,1,0},{1,1,0},{0,0,0}},
{{0,1,0},{0,1,1},{0,0,0}},
{{0,0,0},{1,1,0},{0,1,0}},
{{0,0,0},{0,1,1},{0,1,0}},
{{0,1,0},{0,1,0},{0,1,0}},
{{0,0,0},{1,1,1},{0,0,0}},
{{0,1,0},{1,1,1},{0,0,0}},
{{0,1,0},{1,1,0},{0,1,0}},
{{0,0,0},{1,1,1},{0,1,0}},
{{0,1,0},{0,1,1},{0,1,0}},
{{0,1,0},{1,1,1},{0,1,0}},
};
void DFS(int x,int y)
{
int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
int tx,ty;
for(int i=0;i<4;i++)
{
tx=x+next[i][0];
ty=y+next[i][1];
if(tx>m*3||tx<0||ty>n*3||ty<0)
continue;
if(a[tx][ty]==1&&book[tx][ty]==0)
{
book[tx][ty]=1;
DFS(tx,ty);
}
}
return ;
}
int main()
{
int i,j,k,u,v;
char str[100][100];

while(scanf("%d%d",&m,&n)!=EOF)
{
if(m<0||n<0)
break;
memset(str,0,sizeof(str));
for(i=0;i<m;i++)
{
scanf("\n");
for(j=0;j<n;j++)
{
scanf("%c",&str[i][j]);
}
}

memset(a,0,sizeof(a));
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
{
u=i*3;
for(int i1=0;i1<3;i1++)
{
v=j*3;
for(int j1=0;j1<3;j1++)
{
a[u][v]=b[str[i][j]-'A'][i1][j1];
v++;
}

4000
u++;
}

}
}
int f=0;
memset(book,0,sizeof(book));
for(i=0;i<m*3;i++)
{
for(j=0;j<n*3;j++)
{
if(a[i][j]==1&&book[i][j]==0)
{
book[i][j]=1;
DFS(i,j);
f++;
}
}
}
printf("%d\n",f);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: