您的位置:首页 > 其它

HDU 3555 Bomb(数位DP)

2018-01-27 15:27 405 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 20999    Accepted Submission(s): 7868


[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.
 

[align=left]Sample Input[/align]


3150500

 
[align=left]Sample Output[/align]


0115

Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",so the answer is 15.

题意:给定一个数字N,求出1-N中有多少“49”存在,那么将既没有4也没有9置为状态0,只有数字4置为状态1,有数字49置为状态2.注意状态的更新即可。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
#define eps 1e-7
using namespace std;
/*dp[pos][state]表示到pos位状态为state的数的个数
state有三种:1、dp[i][0]表示长度为i,不含49数的个数
2、dp[i][1]表示长度为i,且最低位为4数的个数
3、dp[i][2]表示长度为i,含有49数的个数*/
long long dp[65][3];
int a[65];
long long dfs(int pos,int state,int limit)
{
if(pos==-1) return state==2;//当位数为-1时如果状态为2返回1
if(!limit&&dp[pos][state]!=-1)
return dp[pos][state];//记忆化搜索
int top=limit?a[pos]:9;//确定本位上限
long long ans=0;
for(int i=0;i<=top;i++)
{
int nstate=state;
if(nstate==0&&i==4)//当状态为0且本位为4时状态置为1
nstate=1;
else if(nstate==1&&i!=4&&i!=9)//当状态为1且本位不是9也不是4的时候把状态置为0
nstate=0;
else if(nstate==1&&i==9)//当状态为1且本位为9时把状态置为2
nstate=2;
ans+=dfs(pos-1,nstate,limit&&i==top);
}
if(!limit) dp[pos][state]=ans;
return ans;
}
long long solve(long long x)
{
int pos=0;
while(x)
{
a[pos++]=x%10;
x/=10;
}
return dfs(pos-1,0,1);
}
int main()
{
int t;
long long n;
scanf("%d",&t);
while(t--)
{
scanf("%I64d",&n);
memset(dp,-1,sizeof(dp));
printf("%I64d\n",solve(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数位dp