您的位置:首页 > 运维架构

POJ 3258 River Hopscotch (二分)

2018-01-27 10:05 417 查看
River Hopscotch

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16881 Accepted: 7054
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units
away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in
order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of Mrocks.

Input

Line 1: Three space-separated integers: L, N, and M 

Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2
2
14
11
21
17

Sample Output
4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
Source

USACO 2006 December Silver

题目链接:http://poj.org/problem?id=3258

题意:有n+2个石头,求移除m个石头使得任意两个石头之间的最小值最大(起点和终点处的石头不能移除)

思路:二分求最大化最小值。

PS:最后输出lb的原因是:当judge()函数返回为1的时候,mid赋值给ub,而这时的mid的值是不符合要求的(比实际的最优解要大),而每次得到的lb的值都要小于等于
实际的最优解,故输出最后一次的lb值。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
using namespace std;

const int INF = 1e9 + 10;
const int N = 5e4+10;
int n,m,l,a
;

int judge(int d){
int last = 0;
for(int i = 1; i < n-m+2; i ++){
int crt = last+1;
while(crt < n+2 && a[crt] - a[last] < d) crt ++;
if(crt == n+2) return 1;
last = crt;
}
return 0;
}

int main(){
while(~scanf("%d%d%d",&l,&n,&m)){
a[0] = 0;
for(int i = 1; i <= n; i ++) scanf("%d",&a[i]);
int lb = 0, ub = INF;
sort(a+1,a+n+1);
a[n+1] = l;
while(lb + 1 < ub){
int mid = (lb + ub) / 2;
if(judge(mid)) ub = mid;
else lb = mid;
}
printf("%d\n",lb);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: