您的位置:首页 > 其它

HDU - 3282 Running Median (动态中位数+优先队列)

2018-01-26 21:11 260 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3282点击打开链接


Running Median

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1199    Accepted Submission(s): 431


Problem Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

 

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving
the total number of signed integers to be processed.

The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space.

The last line in the dataset may contain less than 10 values.

 

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated
by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

 

Sample Input

3
1 9
1 2 3 4 5 6 7 8 9
2 9
9 8 7 6 5 4 3 2 1
3 23
23 41 13 22 -3 24 -31 -11 -8 -7
3 5 103 211 -311 -45 -67 -73 -81 -99
-33 24 56

 

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3
c3cd
5 5 3 -3
-7 -3

 

Source

2009 Greater New York Regional

每到奇数时求中位数

用大根堆和小根堆储存

维护小根堆数量奇数时为大根堆+1偶数时相同 

每次遇到奇数查询小根堆顶元素即可

#include <bits/stdc++.h>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
priority_queue<int > qmax;
priority_queue<int ,vector<int > ,greater <int > >qmin;
int cnt;
int n;
scanf("%d%d",&cnt,&n);
printf("%d %d\n",cnt,(n/2+1));
for(int i=1;i<=n;i++)
{
int mid;
scanf("%d",&mid);
if(qmin.size()==0)
qmin.push(mid);
else
{
if(mid>=qmin.top())
qmin.push(mid);
else
qmax.push(mid);
}
while(qmin.size()!=qmax.size()+1&&qmin.size()!=qmax.size())
{
if(qmin.size()>qmax.size())
{
int mid=qmin.top();
qmin.pop();
qmax.push(mid);
}
else
{
int mid=qmax.top();
qmax.pop();
qmin.push(mid);
}
}
if(i&1)
cout << qmin.top();
if((i+1)%20==0||i==n)
cout << endl;
else if(i&1)
cout << " ";
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: