您的位置:首页 > 其它

zoj 3826 Hierarchical Notation(hash+dfs)

2018-01-26 18:29 369 查看
Hierarchical Notation

Time Limit: 2 Seconds      Memory Limit: 131072 KB

In Marjar University, students in College of Computer Science will learn EON (Edward Object Notation), which is a hierarchical data format that uses human-readable text to transmit data objects consisting of attribute-value pairs. The EON was invented by Edward,
the headmaster of Marjar University.

The EON format is a list of key-value pairs separated by comma ",", enclosed by a couple of braces "{" and "}". Each key-value pair has the form of "<key>":"<value>". <key> is a string consists of alphabets and digits. <value> can be either a string with the
same format of <key>, or a nested EON.

To retrieve the data from an EON text, we can search it by using a key. Of course, the key can be in a nested form because the value may be still an EON. In this case, we will use dot "." to separate different hierarchies of the key.

For example, here is an EON text:

{"headmaster":"Edward","students":{"student01":"Alice","student02":"Bob"}}

For the key "headmaster", the value is "Edward".
For the key "students", the value is {"student01":"Alice","student02":"Bob"}.
For the key "students"."student01", the value is "Alice".

As a student in Marjar University, you are doing your homework now. Please write a program to parse a line of EON and respond to several queries on the EON.


Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an EON text. The number of colons ":" in the string will not exceed 10000 and the length of each key and non-EON value will not exceed 20.

The next line contains an integer Q (0 <= Q <= 1000) indicating the number of queries. Then followed by Q lines, each line is a key for query. The querying keys are in correct format, but some of them may not exist in the EON
text.

The length of each hierarchy of the querying keys will not exceed 20, while the total length of each querying key is not specified. It is guaranteed that the total size of input data will not exceed 10 MB.


Output

For each test case, output Q lines of values corresponding to the queries. If a key does not exist in the EON text, output "Error!" instead (without quotes).


Sample Input

1
{"hm":"Edward","stu":{"stu01":"Alice","stu02":"Bob"}}
4
"hm"
"stu"
"stu"."stu01"
"students"


Sample Output

"Edward"
{"stu01":"Alice","stu02":"Bob"}
"Al
c34f
ice"
Error!


题意:

求每一个key对应的value。

思路:

将字符串转化成数字,存在map里面,map里存的是每个key对应的value的起始下标和结束下标。用dfs只需要搜索一边就可以了。所以我们可以用一个全局变量pos来记录一下当然搜索的位置。

注意在每一层搜索key的不同value的时候,不要破坏之前给的sum值。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
typedef unsigned long long ull;
const int maxn=400005;
char str[maxn],p[maxn];
int len,pos;
map<ull,pair<int,int> > mp;
ull gethash(char c)
{
if(c>='0'&&c<='9')
return c-'0';
if(c>='a'&&c<='z')
return c-'a'+10;
else if(c>='A'&&c<='Z')
return c-'A'+36;
else if(c=='.')
return 62;
else
return 63;
}
void work(ull sum)
{
while(str[pos]!='}')
{
if(str[++pos]=='}')
return;
ull t=sum;//当层下的哈希总和。
while(str[pos]!=':')
{
t=t*131+gethash(str[pos]);
pos++;
}
int l=++pos;
if(str[pos]=='{')
{
work(t*131+gethash('.'));
}
else
while(str[pos+1]!=','&&str[pos+1]!='}')
pos++;
mp[t]=make_pair(l,pos);
pos++;
}
}
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%s",str);
mp.clear();
len=strlen(str);
pos=0;
work(0);
scanf("%d",&n);
for(int i=0; i<n; i++)
{
scanf("%s",p);
int len2=strlen(p);
ull ans=0;
for(int j=0; j<len2; j++)
ans=ans*131+gethash(p[j]);
if(mp.count(ans)!=0)
{
for(int k=mp[ans].first; k<=mp[ans].second; k++)
printf("%c",str[k]);
}
else
printf("Error!");
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: