您的位置:首页 > 其它

ACM题目 - 杭电1020 编码

2018-01-25 16:06 337 查看
Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

Output

For each test case, output the encoded string in a line.

 

Sample Input

2
ABC
ABBCCC

 

Sample Output

ABC
A2B3C

#include<iostream>

#include<string>

using namespace std;

main(){

    int n;

    cin>>n;

    while(n--){

        string a;

        cin>>a;

        int sum=1;

        int t=0,flag=0,x=1;

        for(int i=0;i<a.length()-1;i++){

            if(a[i]==a[i+1]){

                a[i]='1';

            }

         }

        for(int i=0;i<a.length();i++){

            if(a[i]!='1' ){

                if(sum!=1){

                cout<<sum;

                }

                cout<<a[i];

                sum=1;

            }

            else {

                sum++;

             }

         }

         cout<<endl;

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: