您的位置:首页 > 其它

UVA 10557 XYZZY (Floyd+Bellman)

2018-01-24 19:56 495 查看


XYZZY


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 33   Accepted Submission(s) : 4


Problem Description

It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are
winnable. 

Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues
until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 

 

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:
the energy value for room i the number of doorways leaving room i a list of the rooms that are reachable by the doorways leaving room i The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

 

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

 

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

 

Sample Output

hopeless
hopeless
winnable
winnable

//若有正圈,则可以无限增大,但是要判一下该圈能否到达原点。
#include<iostream>
#include<cstdio>
#include<string.h>
#include<string>
#include<algorithm>
const int INF=0x3f3f3f3f;
int n,d[102],rode[102][102],a[102],b[102],c[102][102];
using namespace std;
void init()
{
for(int i=0;i<=100;i++)
d[i]=-INF;
d[1]=100;
for(int i=0;i<=100;i++)
for(int j=0;j<=100;j++)
if(i==j?rode[i][j]=1:rode[i][j]=0);//道路联通记为一,不连通计为0。
}
bool Bellman()
{
for(int i=1;i<n;i++)
{
for(int j=1;j<=n;j++)
{
int from=j;
for(int k=1;k<=b[j];k++)
{
int to=c[j][k];
if(d[to]<d[from]+a[to]&&d[from]+a[to]>0)
{
d[to]=d[from]+a[to];
}
}
}
}
if(d
>0)return 1;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=b[i];j++)
{
int to=c[i][j];
if(d[to]<d[i]+a[to]&&d[i]+a[to]>0&&rode[to]
)//若(n-1)次之后还能更新,则存在正圈,若正圈与终点相通,则
一定能到
return 1;
}
}
return 0;
}
void Floyd()
{
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
for(int k=1;k<=n;k++)
{
if(!rode[j][k])
{
rode[j][k]=rode[j][i]&&rode[i][k];
}
}
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
if(n==-1)break;
int i,j,k;init();
for(i=1;i<=n;i++)
{
scanf("%d%d",&a[i],&b[i]);
for(j=1;j<=b[i];j++)
{
scanf("%d",&c[i][j]);
int q1=i,q2=c[i][j];
rode[q1][q2]=1;
}
}
Floyd();
if(Bellman()) printf("winnable\n");
else printf("hopeless\n");
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: