您的位置:首页 > 其它

树结构练习——排序二叉树的中序遍历

2018-01-24 15:15 239 查看

树结构练习——排序二叉树的中序遍历

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center][/align]

Problem Description

在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
 

Input

输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。

Output

为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
 

Example Input

1
2
2
1 20


Example Output

2
1 20

#include<stdio.h>
#include<stdlib.h>
int a[1000];
int k;
struct node
{
    int date;
    struct node *lchild, *rchild;
};
struct node *creat(struct node *p, int x)
{
    if(p == NULL)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->lchild = NULL;
        p->rchild = NULL;
        p->date = x;
    }
    else
    {
        if(x < p->date)
            p->lchild = creat(p->lchild, x);
        else
            p->rchild = creat(p->rchild, x);
    }
    return p;
}
void zhong(struct node *T)
{
    if(T)
    {
        zhong(T -> lchild);
        a[k++] = T -> date;
        zhong(T -> rchild);
    }
}
int main()
{
    int n,i;
    struct node *T;
    while(~scanf("%d", &n))
    {
        k = 0;
        int x;
        T = NULL;
        while(n--)
        {
            scanf("%d", &x);
            T = creat(T, x);
        }
        zhong(T);
        for(i = 0; i <= k - 1; i++)
        {
            if(i == 0)printf("%d", a[i]);
            else printf(" %d", a[i]);
        }
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: