您的位置:首页 > 其它

求二叉树的层次遍历

2018-01-24 09:40 246 查看

求二叉树的层次遍历

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center][/align]

Problem Description

已知一颗二叉树的前序遍历和中序遍历,求二叉树的层次遍历。

Input

输入数据有多组,输入T,代表有T组测试数据。每组数据有两个长度小于50的字符串,第一个字符串为前序遍历,第二个为中序遍历。

Output

每组输出这颗二叉树的层次遍历。

Example Input

2
abc
bac
abdec
dbeac


Example Output

abc
abcde


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int k;
char a[100],b[100];
struct bittree
{
char data;
struct bittree * ltree,* rtree;
};
void cengci(struct bittree * root)
{
if(root==NULL)
{
return ;
}
int f,r;
f=1;r=1;
struct bittree * s[100],*p;
s[1]=root;
while(f<=r)
{
p=s[f++];
printf("%c",p->data);
if(p->ltree!=NULL)
{
s[++r]=p->ltree;
}
if(p->rtree!=NULL)
{
s[++r]=p->rtree;
}
}
}
struct bittree * create(int len,char * a,char * b)
{
struct bittree * root;
int i;
root=(struct bittree *)malloc(sizeof(struct bittree));
if(len==0)
{
root=NULL;
}
else
{
root->data=a[0];
for(i=0;i<len;i++)
{
if(root->data==b[i])
{
break;
}
}
root->ltree=create(i,a+1,b);
root->rtree=create(len-i-1,a+i+1,b+i+1);
}
return root;
}
int main()
{
int t,len;
struct bittree * root;
scanf("%d",&t);
getchar();
while(t--)
{
k=0;
gets(a);
gets(b);
len=strlen(a);
root=create(len, a, b);
cengci(root);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  山理oj