您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树四:(先序中序)还原二叉树

2018-01-23 20:55 519 查看

数据结构实验之二叉树四:(先序中序)还原二叉树

Time Limit: 1000MS
Memory Limit: 65536KB
[align=center][/align]

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

 

Output

 输出一个整数,即该二叉树的高度。

Example Input

9
ABDFGHIEC
FDHGIBEAC


Example Output

5


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct bittree
{
char data;
struct bittree * l,* r;
};
struct bittree * create(int len,char * st1,char * st2)
{
struct bittree * root;
int i;
if(len==0)
{
return NULL;
}
root=(struct bittree *)malloc(sizeof(struct bittree));
root->data=st1[0];
for(i=0;i<len;i++)
{
if(root->data==st2[i])
{
break;
}
}
root->l=create(i,st1+1,st2);
root->r=create(len-i-1,st1+i+1,st2+i+1);
return root;

}
int houxu(struct bittree * p,int num)
{
if(p!=NULL)
{
num++;
if(houxu(p->l,num)>houxu(p->r,num))
{
return houxu(p->l,num);
}
else
{
return houxu(p->r,num);
}

}
else
{
return num;
}
}
int main()
{
int len,num;
char st1[99],st2[99];
struct bittree * root;
while(scanf("%d %s %s",&len,st1,st2)!=EOF)
{
root=create(len,st1,st2);
num=0;
num=houxu(root,num);
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: