您的位置:首页 > 编程语言 > Java开发

1042. 字符统计(20)-浙大PAT乙级真题java实现

2018-01-23 16:37 691 查看
个人博客:打开链接

1042. 字符统计(20)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST. There ARE numbers and other symbols 1&2&3………..

输出样例:

e 7

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
public static void main(String[] args) throws Exception {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
char[] chars = br.readLine().toLowerCase().toCharArray();
int[] n = new int[26];
for (char c : chars) {
if (c >= 'a' && c <= 'z') {
int t = (int) (c - 'a');
n[t]++;
}
}
int max = 0;
for (int i = 1; i < n.length; i++) {
if (n[max] < n[i]) {
max = i;
}
}
char c = (char) ('a' + max);
System.out.println(c + " " + n[max]);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: