您的位置:首页 > 其它

1036. Boys vs Girls (25)

2018-01-23 16:17 323 查看
1036. Boys vs Girls (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:

3

Joe M Math990112 89

Mike M CS991301 100

Mary F EE990830 95

Sample Output 1:

Mary EE990830

Joe Math990112

6

Sample Input 2:

1

Jean M AA980920 60

Sample Output 2:

Absent

Jean AA980920

NA

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

typedef struct
{
string name;
char gender;
string id;
int grade;
}StuInfo;

int main()
{
#ifdef _DEBUG
//freopen("data.txt", "r+", stdin);
fstream cin("data.txt");
#endif // _DEBUG

StuInfo FHstu, MLstu ,tmp;
FHstu.grade = -1, MLstu.grade = 101;
bool f = false, m = false;
int N;
cin >> N;
while (N--)
{
cin >> tmp.name >> tmp.gender >> tmp.id >> tmp.grade;
if (tmp.gender == 'F')
{
if (tmp.grade > FHstu.grade)
{
FHstu = tmp;
f = true;
}

}
else
{
if (tmp.grade < MLstu.grade)
{
MLstu = tmp;
m = true;
}
}
}
if (f)
printf("%s %s\n", FHstu.name.c_str(), FHstu.id.c_str());
else
printf("Absent\n");
if (m)
printf("%s %s\n", MLstu.name.c_str(), MLstu.id.c_str());
else
printf("Absent\n");
if (f && m)
printf("%d", abs(FHstu.grade - MLstu.grade));
else
printf("NA");

#ifdef _DEBUG
cin.close();
#ifndef _CODEBLOCKS
system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1006