您的位置:首页 > 其它

2018_1_23_poj_2258_回溯

2018-01-23 15:56 253 查看
The Settlers of Catan

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1339 Accepted: 872
Description
Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:

When the game ends, the player who built the longest road gains two extra victory points.

The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).

Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes.

The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.
o      o--o      o

\    /    \    /

o--o      o--o

/    \    /    \

o      o--o      o--o

\    /

o--o


Input
The input will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from
0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.
Output
For each test case, print the length of the longest road on a single line.
Sample Input
3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output
2
12

Source
Ulm Local 1998
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<cstring>
using namespace std;

int n,m,best;
int a[32][32];

bool read(){
scanf("%d%d",&n,&m);
if(n==0&&m==0)return 0;
fill(&a[0][0],&a[0][0]+32*32,0);
int x,y;
while(m--){
scanf("%d%d",&x,&y);
a[x][y]=a[x][y]=1;
}
return 1;
}

void visit(int i,int l){
for(int j=0;j<n;j++)
if(a[i][j]){
a[i][j]=a[j][i]=0;
visit(j,l+1);
a[i][j]=a[j][i]=1;
}
best=best<l?l:best;
}

void solve(){
best=0;
for(int i=0;i<n;i++)
visit(i,0);
printf("%d\n",best);
}

int main(){
while(read())solve();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: