您的位置:首页 > 其它

2018_1_22_poj_2013_重新排序

2018-01-22 20:02 363 查看
Symmetric Order

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14443 Accepted: 8568
Description
In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as
the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names
belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.

Input
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one
per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

Output
For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
Sample Input
7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0

Sample Output
SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill

Source
Mid-Central USA 2004
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;

struct AA{
string s;
int i;
};

bool cmp(AA a,AA b){
return a.i<b.i;
}
using namespace std;
int main(){
int n,z=1;
while(scanf("%d",&n)!=EOF){
if(n==0)return 0;
vector<AA> v;
printf("SET %d\n",z++);
for(int i=0;i<n;i++){
AA t;
cin>>t.s;
if(i%2==0)t.i=i/2;
else t.i=n-i/2;
v.push_back(t);
}
sort(v.begin(),v.end(),cmp);
for(int i=0;i<v.size();i++)
cout<<v[i].s<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: