您的位置:首页 > 其它

ZOJ 1005 Jugs

2018-01-22 09:11 323 查看
Jugs点我找原题Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special JudgeIn the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps arefill A 
fill B 
empty A 
empty B 
pour A B 
pour B A 
successwhere "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.You may assume that the input you are given does have a solution.InputInput to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.OutputOutput from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 4
5 7 3

Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success
题目大意:给一个水桶A和一个水桶B,B的容量比A大,对水桶只能进行三个操作,1、加满水;2.倒空;3.将一个桶里的水倒到另一个中去,如果倒的那个桶已经倒空或者被倒水那个桶已经满了,那么停止倒水。求将B桶中水装到N加仑的方法(只要求出一个可行解就行)
方法:
如果A中没有水,将A倒满,否则不操作
把A中的水倒入B
B中的水超过N加仑,将B倒空
循环,直到B中水正好为N加仑
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
int main(int argc, char *argv[])
{
int aa,bb,n;
int a,b;
while(cin>>a>>b>>n)
{
aa=bb=0;
while(bb!=n)
{
if(aa==0) {cout<<"fill A"<<endl;aa=a;}
cout<<"pour A B"<<endl;
if(bb+aa>b) {aa=aa+bb-b;bb=0;cout<<"empty B"<<endl;}
else {bb+=aa;aa=0;}
}
cout<<"success"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: