您的位置:首页 > 其它

ZOJ 1004 Anagrams by Stack

2018-01-22 09:10 405 查看
Anagrams by Stack点我找原题
Time Limit: 2 Seconds      Memory Limit: 65536 KB
How can anagrams result from sequences of stack operations? There are two
sequences of stack operators which can convert TROT to TORT: [
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program
should, given pairs of words produce sequences of stack operations which convert
the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair
of input lines is to be considered as a source word (which does not include the
end-of-line character). The second line (again, not including the end-of-line
character) of each pair is a target word. The end of input is marked by end of
file.

Output

For each input pair, your program should produce a sorted list of valid
sequences of i and o which produce the target word from the source
word. Each list should be delimited by [
]
and the sequences should be printed in "dictionary order". Within each
sequence, each i and o is followed by a single space and each
sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

We will use the symbol i (in) for push and o (out) for pop
operations for an initially empty stack of characters. Given an input word, some
sequences of push and pop operations are valid in that every character of the
word is both pushed and popped, and furthermore, no attempt is ever made to pop
the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o ois valid, but
i i o is not (it's too short), neither is
i i o o o i(there's an illegal pop of an empty stack)
Valid sequences yield rearrangements of the letters in an input word. For
example, the input word FOO and the sequence i i o i o o produce the
anagram OOF. So also would the sequence i i i o o o. You are to write a
program to input pairs of words and output all the valid sequences of i
and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]
解题思路:本题讲述的是让你输入两个字符串序列,判断能否通过对第一个字符串进行进栈出栈操作得到第二个字符串,若能则输出所有能达到的进出栈操作过程。通过全排列得到所有合法的一组[i,o]操作过程,按照这个操作过程,判断得到的新字符串与第二个字符串是否完全一致,若能则表明此操作过程可行,输出。
本题我彻底理解了搜索中的回溯思想,可以把递归枚举的思路看成一棵树,当
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <stack>
#define M 100
using namespace std;
char str1[M],str2[M],str3[M],str4[M];
int ii;
stack<char> s;
void dfs(int push,int pop,int len)
{
if(push==pop&&push<len)
{
str3[ii++]='i';
push++;
dfs(push,pop,len);
}
else if(push>pop&&push<len)
{
int i=ii,p=push;
str3[ii++]='i';
push++;
dfs(push,pop,len);
push=p;ii=i; //回溯时要保存的数据
str3[ii++]='o';
pop++;
dfs(push,pop,len);
}
else if(push>pop&&push==len)
{
str3[ii++]='o';
pop++;
dfs(push,pop,len);
}
else if(push==pop&&push==len)
{
int i,j,k;
j=0;k=0;
for(i=0;str3[i]!='\0';i++)
{
if(str3[i]=='i') s.push(str1[j++]);
else if(str3[i]=='o')
{
str4[k++]=s.top();
s.pop();
}
}
if(strcmp(str2,str4)==0)
{
for(i=0;str3[i]!='\0';i++) cout<<str3[i]<<" ";
cout<<endl;
}

memset(str4,0,sizeof(str4));
return ;
}
}
int main(int argc, char *argv[])
{
int len,l;
while(scanf("%s%s",str1,str2)!=EOF)
{
memset(str3,0,sizeof(str3));
ii=0;
len=strlen(str1);
l=strlen(str2);
if(len!=l)
{
cout<<"["<<endl<<"]"<<endl;
continue;
}
cout<<"["<<endl;
dfs(0,0,len);
cout<<"]"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: