您的位置:首页 > 其它

POJ 1065 Wooden Sticks(贪心,)

2018-01-21 22:35 405 查看
Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be
2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case,
and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


Sample Output
2
1
3

题目理解:

            开头花费时间1,如果后面有木棒的长度l和重量w都大于等于前一根,那就不用花时间。简单来说,就是让尽量多木棒能        接在其他木棒后面,贪心题。

解题思路:

        sort排序自定义以l或者w递增排序,然后按正序判断后面是否有木棒可以免费接,因为我们一开始已经以l(w)作排序,所以直接以w(l)比较,如果可以接上,更新刚接上的木棒的l(w),因为接上这根木棒,后面可能还有木棒能继续接。每一次判断前都要判断是否已经接过了(1 用标记数组标记是否用过 2 数据清0,判断数据是否为0)

重点: 1:标记判断

           2:排序对比,尾部更新。

下面附上代码:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;
struct mubang
{
int l;
int w;
}mb[5005];
int cmp(mubang a,mubang b)
{
if(a.l<b.l)
return 1;
if(a.l==b.l&&a.w<b.w)
return 1;
return 0;
}
int main()
{
int n,i,j,cas,ok[5005],ans=0,wei;
cin>>cas;
while(cas--)
{
ans=0;
memset(ok,0,sizeof(ok));
cin>>n;
for(i=0;i<n;i++)
cin>>mb[i].l>>mb[i].w;
sort(mb,mb+n,cmp);
for(i=0;i<n;i++)
{
if(ok[i]==1)
continue;
ans++;
wei=mb[i].w;
for(j=i+1;j<n;j++)
{
if(ok[j]==1)
continue;
if(mb[j].w>=wei)
{
ok[j]=1;
wei=mb[j].w;
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: