您的位置:首页 > 其它

hdu 1944 S-Nim(博弈论-求SG函数)

2018-01-21 20:46 399 查看
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:

The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

The players take turns chosing a heap and removing a positive number of beads from it.

The first player not able to make a move, loses.

Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:

Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

If the xor-sum is 0, too bad, you will lose.

Otherwise, move such that the xor-sum becomes 0. This is always possible.

It is quite easy to convince oneself that this works. Consider these facts:

The player that takes the last bead wins.

After the winning player's last move the xor-sum will be 0.

The xor-sum will change after every move.

Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win.

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove
a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it?

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position.
This means, as expected, that a position with no legal moves is a losing position.

InputInput consists of a number of test cases.

For each test case: The rst line contains a number k (0 < k <= 100) describing the size of S, followed by k numbers si (0 < si <= 10000) describing S. The second line contains a number m (0 < m <= 100) describing the number of positions to evaluate. The next
m lines each contain a number l (0 < l <= 100) describing the number of heaps and l numbers hi (0 <= hi <= 10000) describing the number of beads in the heaps.

The last test case is followed by a 0 on a line of its own.OutputFor each position:

If the described position is a winning position print a 'W'.

If the described position is a losing position print an 'L'.

Print a newline after each test case.Sample Input
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0

Sample Output
LWW
WWL


题目大意:nim游戏变形,每次每堆石子只能取出恰好给定的数值之一的石子,如石子数还有10,可取数字为(2,5,7,13),那实际上取的方法就只有:每次取2个总共取5次,或每次取5个总共取2次,7和13实际上并没有什么用

思路,将SG函数求出来然后求nim和

SG函数求法

void getSG()
{
memset(SG,0,sizeof SG);
for(int i=1;i<=10005;i++){//每堆石子的石子数最大值为10000,所以循环至10000就好了
memset(vis,0,sizeof vis);//vis数组用于标记当前mex集合里有哪些元素,因为每堆石子能够构成它的元素的集合可能是不同的,
//所以每次都需要将vis数组置0
for(int j=1;j<=N;j++)
{
if(num[j]>i)continue;//如果当前石子总数小于想取的石子数num[j],那就不取,所以continue了
vis[SG[i-num[j]]]=1;//如果能取,那么就是取的这一堆石子数肯定小于i,所以它的SG值肯定已经算过了,由SG函数定义可知
//所取石子数的对应SG值肯定是总石子数为i所对应SG函数的mex集合中的元素,于是将其标记
}
for(int j=0;;j++)if(!vis[j]){//从小到大找不在集合中的最小非负整数
SG[i]=j;
break;//找到就不用找了
}
}
}
这里vis数组只需要开100多一点就OK了,因为题目所给的石子的堆数至多只有100,那么SG值顶多也就100(因为最坏情况是每堆的SG值均不同),至于求nim和就异或
AC代码

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
int SG[10005];
int vis[105];
int num[105];
int N,M;
void getSG()
{
memset(SG,0,sizeof SG);
for(int i=1;i<=10005;i++){
memset(vis,0,sizeof vis);
for(int j=1;j<=N;j++)
{
if(num[j]>i)continue;
vis[SG[i-num[j]]]=1;
}
for(int j=0;;j++)if(!vis[j]){
SG[i]=j;
break;
}
}
}
int main()
{
while(scanf("%d",&N))
{
if(N==0)break;
for(int i=1;i<=N;i++)scanf("%d",&num[i]);
getSG();
scanf("%d",&M);
int n;
for(int i=0;i<M;i++){
scanf("%d",&n);
int temp=0,tempnum;
for(int j=0;j<n;j++){
scanf("%d",&tempnum);
temp^=SG[tempnum];
}
if(temp)printf("W");
else printf("L");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: