您的位置:首页 > 其它

L2-002. 链表去重

2018-01-21 15:28 204 查看


L2-002. 链表去重

时间限制

300 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

陈越

给定一个带整数键值的单链表L,本题要求你编写程序,删除那些键值的绝对值有重复的结点。即对任意键值K,只有键值或其绝对值等于K的第一个结点可以被保留。同时,所有被删除的结点必须被保存在另外一个链表中。例如:另L为21→-15→-15→-7→15,则你必须输出去重后的链表21→-15→-7、以及被删除的链表-15→15。

输入格式:

输入第一行包含链表第一个结点的地址、以及结点个数N(<= 105 的正整数)。结点地址是一个非负的5位整数,NULL指针用-1表示。

随后N行,每行按下列格式给出一个结点的信息:

Address Key Next

其中Address是结点的地址,Key是绝对值不超过104的整数,Next是下一个结点的地址。

输出格式:

首先输出去重后的链表,然后输出被删除结点组成的链表。每个结点占一行,按输入的格式输出。

输入样例:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

输出样例:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1


#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
// 10w个结点组成数组,数组的下标和结点里面的address都为结点的地址
struct node {
int address;
int value;
int next;
};

int main()
{
//freopen("data.txt", "r", stdin);
vector<node> main_list(100000); // 储存主链表
vector<node> sub_list; // 储存重复元素的链表
bool key[10001] = { false }; // 检查某个值的绝对值是否出现过,出现过为true;
int first, N; // first为起始坐标
bool flag = false;
cin >> first >> N;
for (int i = 0; i < N; i++)
{
node n;
cin >> n.address >> n.value >> n.next;
main_list[n.address] = n;
}

node n = main_list[first];
while (1)
{
printf("%05d %d ", n.address, n.value);
key[abs(n.value)] = true;
if (n.next == -1) {
cout << -1 << endl; break;
}
n = main_list[n.next];
while (key[abs(n.value)] == true)
{
sub_list.push_back(n);
if (n.next == -1) {
flag = true; break;
}
n = main_list[n.next];
}
if (flag) {
cout << -1 << endl; break;
}
else
printf("%05d\n", n.address);
}
if (sub_list.size())
{
for (int i = 0; i < sub_list.size() - 1; i++)
{
printf("%05d %d %05d\n", sub_list[i].address, sub_list[i].value, sub_list[i + 1].address);
}
printf("%05d %d -1\n", sub_list[sub_list.size() - 1].address, sub_list[sub_list.size() - 1].value);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: