您的位置:首页 > Web前端

2018_1_20_The Circumference of the Circle_圆周_2242

2018-01-20 21:24 218 查看
Language:
The Circumference of the Circle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9133 Accepted: 5337
Description
To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.

Your job is to calculate the circumference of the unique circle that intersects all three points.

Input
The input will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three
points will never exceed a million. Input is terminated by end of file.
Output
For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately
3.141592653589793.
Sample Input
0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output
3.14
4.44
6.28
31.42
62.83
632.24
3141592.65

Source
Ulm Local 1996

#include<iostream>

#include<string>

#include<vector>

#include<algorithm>

#include<cmath>

using namespace std;

const double pi=4*atan(1.0);

double edge(double a,double b,double c,double d){

    return sqrt((a-c)*(a-c)+(b-d)*(b-d));

}

int main(){

    double x0,x1,x2,y0,y1,y2;

    while(scanf("%lf%lf%lf%lf%lf%lf",&x0,&y0,&x1,&y1,&x2,&y2)!=EOF){

        double s=fabs((x0-x1)*(y0-y2)-(y0-y1)*(x0-x2))/2.0;

        printf("%.2lf\n",

        edge(x0,y0,x1,y1)*edge(x0,y0,x2,y2)*edge(x1,y1,x2,y2)/s/2*pi);

    }

    return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: