您的位置:首页 > Web前端

HDU 1829 A Bug's Life(种类并查集)

2018-01-20 20:21 387 查看
Problem Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

 

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
beha
4000
vior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

 

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

 

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

HintHuge input,scanf is recommended.

思路:

这题应该是种类并查集中较简单类型,只有两类,但是我还是看了好久才看明白,菜哭(⋟﹏⋞)

核心算法就涉及到两处:

一、寻找根时 路径压缩 顺带 归类,二、根节点合并时,根的归类。

首先,开两个数组  dis来记录  每点  与  父节点  的种类关系(这题中某点与其父节点种类相同用0否则用1),f记录父节点下标。

a,b分别为新增树的节点,fa,fb分别为ab的根节点

1.寻找根节点

int getf(int x){
if(f[x]==x)return x;//找到根节点直接返回

//用t暂存根节点下标,因为回溯时,要更新每个节点与根节点关系 需要使用该点的父节点
int t=getf(f[x]);

/*
因为是回溯的,所以dis[f[x]]是x父节点与根节点关系,dis[x]是x与x父节点关系

初始dis[x]    0   0   1   1
dis[f[x]]     1   0   1   0
更新dis[x]    1   0   0   1
*/
dis[x]=(dis[x]+dis[f[x]])%2;

f[x]=t;//路径压缩

//到这里dis[x]已经变为与根节点的关系,f[x]已经链接到根节点
return f[x];
}

2.合并

f[fb]=fa;   //fb指向fa

//dis[a]现在存的是a与fa关系,dis[b]同理
//根据a与fa关系,b与fb关系,ab性别相反,可以得到fb与fa关系
dis[fb]=(dis[a]+dis[b]+1)%2;


代码:

#include<stdio.h>

int f[2005],dis[2005]; //f记录父节点,dis记录与父节点关系

int getf(int x){
if(f[x]==x)return x;//找到根节点直接返回

//用t暂存根节点下标,因为回溯时,要更新每个节点与根节点关系时 需要使用该点的父节点
int t=getf(f[x]);

/*
因为是回溯的,所以dis[f[x]]是x父节点与根节点关系,dis[x]是x与x父节点关系

初始dis[x] 0 0 1 1
dis[f[x]] 1 0 1 0
更新dis[x] 1 0 0 1
*/
dis[x]=(dis[x]+dis[f[x]])%2;

f[x]=t;//路径压缩

//到这里dis[x]已经变为与根节点的关系,f[x]已经链接到根节点
return f[x];
}

int main(){
int T,www=0;
scanf("%d",&T);
while(T--){
int n,m,a,b,fa,fb,flag=0,i;
scanf("%d%d",&n,&m);

//初始化
for(i=1;i<=n;i++){
f[i]=i;
dis[i]=0;
}
while(m--){
scanf("%d%d",&a,&b);
if(flag)continue;
fa=getf(a);
fb=getf(b);
if(fa==fb){ //如果根相同,说明能够充分推出a b是否为同性恋
if(dis[a]==dis[b])flag=1;
}
else{
f[fb]=fa;
//dis[a]现在存的是a与fa关系,dis[b]同理
//根据a与fa关系,b与fb关系,ab性别相反,可以得到fb与fa关系
dis[fb]=(dis[a]+dis[b]+1)%2;
}
}
printf("Scenario #%d:\n",++www);
if(flag)printf("Suspicious bugs found!\n\n");
else printf("No suspicious bugs found!\n\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: