您的位置:首页 > 其它

HDU-4989-Summary(STL之set)

2018-01-20 19:51 260 查看

Summary

[align=left]Problem Description[/align]
Small W is playing a summary game. Firstly, He takes N numbers. Secondly he takes out every pair of them and add this two numbers, thus he can get N*(N - 1)/2 new numbers. Thirdly he deletes the repeated number of the new numbers.
Finally he gets the sum of the left numbers. Now small W want you to tell him what is the final sum.
[align=left]Input[/align]
Multi test cases, every case occupies two lines, the first line contain n, then second line contain n numbers a1, a2, ……an separated by exact one space. Process to the end of file.

[Technical Specification]

2 <= n <= 100

-1000000000 <= ai <= 1000000000
[align=left]Output[/align]
For each case, output the final sum.
[align=left]Sample Input[/align]

4
1 2 3 4
2
5 5

[align=left]Sample Output[/align]

25
10
HintFirstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.

#include<bits/stdc++.h>
using namespace std;

int main() {
int n,a[105];
set<int>s;
while(~scanf("%d",&n)) {
long long sum=0;
s.clear();//清空!
for(int i = 0; i < n; i++) {
scanf("%d",&a[i]);
}
for(int i=0; i < n; i++) {
for(int j=i+1; j<n; j++) {
s.insert(a[i]+a[j]);
}
}
set<int>::iterator it;//定义前向迭代器
for(it=s.begin(); it!=s.end(); it++)
sum +=*it;
printf("%lld\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  STL set