您的位置:首页 > 其它

PAT(甲级)1008. Elevator (20)

2018-01-19 19:58 549 查看

Elevator (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意:电梯初始在第0层,上升一层需6s,下降一层需4s,每次开门停留5s 给出电梯需停的楼层 求完成所需时间

分析:直接求即可 无坑点

#include <iostream>
#include<cstdio>
#define maxn 10010
using namespace std;

int main()
{
int n,s=0;
int rec[maxn];
scanf("%d",&n);
rec[0]=0;
for(int i=1;i<=n;++i){
scanf("%d",&rec[i]);
if(rec[i]>=rec[i-1])
s+=6*(rec[i]-rec[i-1]);
else
s+=4*(rec[i-1]-rec[i]);
}
s+=n*5;
printf("%d",s);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: