您的位置:首页 > 其它

HDU 2850 Load Balancing (贪心+优先队列)

2018-01-19 14:57 351 查看

Load Balancing

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1129    Accepted Submission(s): 449
Special Judge


[align=left]Problem Description[/align]In the Wide Web World, Which web server was popular in web site? Apache, nginx, lighttpd? Baidu.com use Apache, and many web sites like 163.com use nginx. Why? Its configuration is very simple, and it has very powerful load balancing features.

How does load balancing work? Load balancing is a technique to spread work between two or more computers in order to get optimal resource utilization, maximize throughput, and minimize response time. Wiskey very curious about this technology and he wants to build a simple load balancing model.

He define the web site has M servers, and N jobs need be done. Each job has a processing time T; we seek to assign each job to one of the servers so that the loads placed on all servers are as "balanced" as possible. The "balanced" mean the Minimize it (max {TMi} - min {TMj}). TMi is the server i total time cost.

But, as Wiskey Know, this scheduling problem of finding an assignment of minimum gap is NP-hard. 

Can you write a better load balancing than Wiskey? Challenge it~!
 
[align=left]Input[/align]The first integer C represents the number of cases, And C cases followed.

Each test case contains a single integer N (1<=N<=100000) and M (1<=M<=100). The next N line contains integers, meaning the time of job T1, T2Tn. (1<=Ti<=1000000)
 
[align=left]Output[/align]For each test case, first output the N, and follows N numbers mean the job i assign to which server. The servers number count from 0. 
[align=left]Sample Input[/align]
2
6 3
2 3 4 6 2 2
6 3
6 4 3 2 2 2 
[align=left]Sample Output[/align]
6
0 1 2 0 1 2
6
0 1 1 2 2 2
Hint
Hint
This problem is special judge, if your assign plan (max {TMi} -min {TMj}) <= my answer + 1000, it be consider Accept.从耗时最多的开始分配,每次分配给当前服务器任务最少的
#include<bits/stdc++.h>
int d[100003];
using namespace std;
struct node
{
long long time;
int loca;
}g[100003];
bool cmp1(node a,node b)
{
return a.time>b.time;
}
struct node2
{
long long time;
int dec;
};
bool operator<(node2 a,node2 b)
{
return a.time>b.time;
}
priority_queue<node2> P;
int main()
{
int T;scanf("%d",&T);
while(T--)
{
int n,m;scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
{
long long tt;[/b]scanf("%lld",&tt);
g[i].loca=i,g[i].time=tt;
}
sort(g,g+n,cmp1);
for(int i=0;i<m;i++)
{
node2 e;e.dec=i,e.time=0;
P.push(e);
}
for(int i=0;i<n;i++)
{
node e;e=g[i];
node2 t=P.top();P.pop();
d[e.loca]=t.dec;
t.time+=e.time;
P.push(t);
}
while(!P.empty())P.pop();
printf("%d\n",n);
for(int i=0;i<n-1;i++)
printf("%d ",d[i]);
printf("%d\n",d[n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: